جزئیات آسیب‌پذیری

CVE-2026-59948

composer composer

Composer: Arbitrary file write outside vendor via malicious transitive package name

CVSS 3.1
7.0بالا

شرح رسمی (انگلیسی)

Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a maliciously crafted package from an untrusted repository other than Packagist.org or Private Packagist can cause Composer to write attacker-controlled files outside the vendor directory and outside the project during install or update by using an invalid package name that is not correctly validated before dependency-resolution results are written or installed. This issue is fixed in versions 2.2.29 and 2.10.2.

امتیازهای CVSS

امتیازنسخهمنبعبردار
7.0بالا 3.1 CVEProject cvelistV5 (CNA) (GitHub_M) CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
composer composer >= 1.0, < 2.2.29 CVEProject cvelistV5 (CNA)
composer composer >= 2.3.0, < 2.10.2 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۵
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۵/۰۴/۱۷
آخرین به‌روزرسانی
۱۴۰۵/۰۴/۱۸
وضعیت
منتشرشده
صادرکننده (CNA)
GitHub_M

پیش‌بینی بهره‌برداری (EPSS)

۰٫۱۳٪
احتمال بهره‌برداری در ۳۰ روز
۳٫۱٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
خیر
وضعیت بهره‌برداری
ندارد
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-22
    Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
  • CWE-787
    Out-of-bounds Write