جزئیات آسیب‌پذیری

CVE-2026-49042

Apache Software Foundation Apache Camel

Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters

CVSS 3.1
7.3بالا

شرح رسمی (انگلیسی)

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

امتیازهای CVSS

امتیازنسخهمنبعبردار
7.3بالا 3.1 CISA ADP / Vulnrichment (CISA-ADP) CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
Apache Software Foundation Apache Camel 4.19.0 ≤ v ≤ 4.20.0 CVEProject cvelistV5 (CNA)
Apache Software Foundation Apache Camel 4.8.0 ≤ v ≤ 4.18.2 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۲
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۵/۰۴/۱۵
آخرین به‌روزرسانی
۱۴۰۵/۰۴/۱۶
وضعیت
منتشرشده
صادرکننده (CNA)
apache

پیش‌بینی بهره‌برداری (EPSS)

۰٫۶۹٪
احتمال بهره‌برداری در ۳۰ روز
۵۳٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
بله
وضعیت بهره‌برداری
ندارد
اثر فنی
جزئی

ضعف‌ها (CWE)

  • CWE-20
    Improper Input Validation