جزئیات آسیب‌پذیری

CVE-2026-48717

OpenIdentityPlatform OpenAM

OpenAM OAuth Authorization Bypass via PKCE Challenge

CVSS 4.0
9.1بحرانی

شرح رسمی (انگلیسی)

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, AuthorizationCodeGrantTypeHandler requires a code_verifier only when the realm-wide codeVerifierEnforced setting is enabled, even when an authorization code stores a code_challenge. Because that setting is disabled by default, an attacker who intercepts a PKCE-protected authorization code can omit code_verifier and redeem the code, while an explicitly incorrect verifier is rejected. Public clients are directly affected, and confidential-client exploitation additionally requires client authentication material or another redemption context. This issue is fixed in version 16.1.1.

امتیازهای CVSS

امتیازنسخهمنبعبردار
9.1بحرانی 4.0 CVEProject cvelistV5 (CNA) (GitHub_M) CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
OpenIdentityPlatform OpenAM < 16.1.1 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۳
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۵/۰۶/۲۴
آخرین به‌روزرسانی
۱۴۰۵/۰۶/۲۴
وضعیت
منتشرشده
صادرکننده (CNA)
GitHub_M

پیش‌بینی بهره‌برداری (EPSS)

۰٫۵۲٪
احتمال بهره‌برداری در ۳۰ روز
۴۴٫۹٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
خیر
وضعیت بهره‌برداری
ندارد
اثر فنی
جزئی

ضعف‌ها (CWE)

  • CWE-285
    Improper Authorization