جزئیات آسیب‌پذیری

CVE-2026-31908

Apache Software Foundation Apache APISIX

Apache APISIX: forward auth plugin allows header injection

CVSS 3.1
9.1بحرانی

شرح رسمی (انگلیسی)

Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

امتیازهای CVSS

امتیازنسخهمنبعبردار
9.1بحرانی 3.1 CISA ADP / Vulnrichment (CISA-ADP) CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
Apache Software Foundation Apache APISIX 2.12.0 ≤ v ≤ 3.15.0 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۲
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۵/۰۱/۲۵
آخرین به‌روزرسانی
۱۴۰۵/۰۱/۲۷
وضعیت
منتشرشده
صادرکننده (CNA)
apache

پیش‌بینی بهره‌برداری (EPSS)

۰٫۵۲٪
احتمال بهره‌برداری در ۳۰ روز
۴۴٫۳٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
بله
وضعیت بهره‌برداری
ندارد
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-75
    Failure to Sanitize Special Elements into a Different Plane (Special Element Injection)