جزئیات آسیب‌پذیری

CVE-2026-23984

Apache Software Foundation Apache Superset

Apache Superset: SQLLab Read-Only Bypass on PostgreSQL

CVSS 4.0
7.1بالا

شرح رسمی (انگلیسی)

An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a PostgreSQL database connection. While the system effectively blocks standard Data Manipulation Language (DML) statements (e.g., INSERT, UPDATE, DELETE) on read-only connections, it fails to detect them in specially crafted SQL statements. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

امتیازهای CVSS

امتیازنسخهمنبعبردار
7.1بالا 4.0 CVEProject cvelistV5 (CNA) (apache) CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
Apache Software Foundation Apache Superset v < 6.0.0 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۲
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۴/۱۲/۰۵
آخرین به‌روزرسانی
۱۴۰۴/۱۲/۰۵
وضعیت
منتشرشده
صادرکننده (CNA)
apache

پیش‌بینی بهره‌برداری (EPSS)

۰٫۴٪
احتمال بهره‌برداری در ۳۰ روز
۳۵٫۴٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
خیر
وضعیت بهره‌برداری
ندارد
اثر فنی
جزئی

ضعف‌ها (CWE)

  • CWE-863
    Incorrect Authorization