جزئیات آسیب‌پذیری

CVE-2026-22034

jvoisin snuffleupagus

Snuffleupagus vulnerable to RCE on instances with upload validation enabled but without the VLD package

CVSS 4.0
9.2بحرانی

شرح رسمی (انگلیسی)

Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of the upstream validation scripts based on Vulcan Logic Disassembler (VLD) while the VLD extension is not available to the CLI SAPI, all files from multipart POST requests are evaluated as PHP code. The issue was fixed in version 0.13.0.

امتیازهای CVSS

امتیازنسخهمنبعبردار
9.2بحرانی 4.0 CVEProject cvelistV5 (CNA) (GitHub_M) CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
jvoisin snuffleupagus < 0.13.0 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۸
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۴/۱۰/۱۸
آخرین به‌روزرسانی
۱۴۰۴/۱۰/۱۸
وضعیت
منتشرشده
صادرکننده (CNA)
GitHub_M

پیش‌بینی بهره‌برداری (EPSS)

۰٫۷۱٪
احتمال بهره‌برداری در ۳۰ روز
۵۳٫۸٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
بله
وضعیت بهره‌برداری
اثبات مفهوم
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-636
    Not Failing Securely ('Failing Open')