جزئیات آسیب‌پذیری

CVE-2026-2052

Marketing Fire Widget Options - ExtendedMarketingFire Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets

Widget Options <= 4.2.2 - Authenticated (Contributor+) Remote Code Execution via Display Logic

CVSS 3.1
8.8بالا

شرح رسمی (انگلیسی)

The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.

امتیازهای CVSS

امتیازنسخهمنبعبردار
8.8بالا 3.1 CVEProject cvelistV5 (CNA) (Wordfence) CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
Marketing Fire, LLC Widget Options - Extended v ≤ 5.3.2 CVEProject cvelistV5 (CNA)
MarketingFire Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets v ≤ 4.2.2 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۶
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۵/۰۲/۱۲
آخرین به‌روزرسانی
۱۴۰۵/۰۲/۱۴
وضعیت
منتشرشده
صادرکننده (CNA)
Wordfence

پیش‌بینی بهره‌برداری (EPSS)

۰٫۷۷٪
احتمال بهره‌برداری در ۳۰ روز
۵۵٫۹٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
خیر
وضعیت بهره‌برداری
ندارد
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-94
    Improper Control of Generation of Code ('Code Injection')