جزئیات آسیب‌پذیری

CVE-2026-12957

Amazon Web Services Language Servers for AWS

Arbitrary Code Execution in Language Servers for AWS

CVSS 4.0
8.5بالا

شرح رسمی (انگلیسی)

Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

امتیازهای CVSS

امتیازنسخهمنبعبردار
8.5بالا 4.0 CVEProject cvelistV5 (CNA) (AMZN) CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
7.8بالا 3.1 CVEProject cvelistV5 (CNA) (AMZN) CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
Amazon Web Services Language Servers for AWS v < 1.65.0 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۲
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۵/۰۴/۰۲
آخرین به‌روزرسانی
۱۴۰۵/۰۴/۰۲
وضعیت
منتشرشده
صادرکننده (CNA)
AMZN

پیش‌بینی بهره‌برداری (EPSS)

۰٫۲۳٪
احتمال بهره‌برداری در ۳۰ روز
۱۴٫۳٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
خیر
وضعیت بهره‌برداری
ندارد
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-732
    Incorrect Permission Assignment for Critical Resource