جزئیات آسیب‌پذیری

CVE-2025-69262

pnpm pnpm

pnpm vulnerable to Command Injection via environment variable substitution

CVSS 3.1
7.6بالا

شرح رسمی (انگلیسی)

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

امتیازهای CVSS

امتیازنسخهمنبعبردار
7.6بالا 3.1 CVEProject cvelistV5 (CNA) (GitHub_M) CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
pnpm pnpm >=6.25.0, < 10.27.0 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۲
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۴/۱۰/۱۸
آخرین به‌روزرسانی
۱۴۰۴/۱۲/۰۷
وضعیت
منتشرشده
صادرکننده (CNA)
GitHub_M

پیش‌بینی بهره‌برداری (EPSS)

۱٫۰۴٪
احتمال بهره‌برداری در ۳۰ روز
۶۴٫۱٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
خیر
وضعیت بهره‌برداری
اثبات مفهوم
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-78
    Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')
  • CWE-94
    Improper Control of Generation of Code ('Code Injection')