جزئیات آسیب‌پذیری

CVE-2025-58766

dyad-sh dyad

Dyad Vulnerable to Remote Code Execution via Top-level Navigation in Preview Window

CVSS 3.1
9.1بحرانی

شرح رسمی (انگلیسی)

Dyad is a local AI app builder. A critical security vulnerability has been discovered that affected Dyad v0.19.0 and earlier versions that allows attackers to execute arbitrary code on users' systems. The vulnerability affects the application's preview window functionality and can bypass Docker container protections. An attacker can craft web content that automatically executes when the preview loads. The malicious content can break out of the application's security boundaries and gain control of the system. This has been fixed in Dyad v0.20.0 and later.

امتیازهای CVSS

امتیازنسخهمنبعبردار
9.1بحرانی 3.1 CVEProject cvelistV5 (CNA) (GitHub_M) CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
dyad-sh dyad < 0.20.0 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۳
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۴/۰۶/۲۶
آخرین به‌روزرسانی
۱۴۰۴/۰۶/۲۶
وضعیت
منتشرشده
صادرکننده (CNA)
GitHub_M

پیش‌بینی بهره‌برداری (EPSS)

۰٫۴۴٪
احتمال بهره‌برداری در ۳۰ روز
۳۸٫۵٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
خیر
وضعیت بهره‌برداری
ندارد
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-94
    Improper Control of Generation of Code ('Code Injection')