جزئیات آسیب‌پذیری

CVE-2025-48956

vllm-project vLLM

vLLM API endpoints vulnerable to Denial of Service Attacks

CVSS 3.1
7.5بالا

شرح رسمی (انگلیسی)

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.

امتیازهای CVSS

امتیازنسخهمنبعبردار
7.5بالا 3.1 CVEProject cvelistV5 (CNA) (GitHub_M) CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
vllm-project vLLM >= 0.1.0, < 0.10.1.1 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۳
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۴/۰۵/۳۰
آخرین به‌روزرسانی
۱۴۰۴/۰۵/۳۰
وضعیت
منتشرشده
صادرکننده (CNA)
GitHub_M

پیش‌بینی بهره‌برداری (EPSS)

۰٫۵۶٪
احتمال بهره‌برداری در ۳۰ روز
۴۷٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
بله
وضعیت بهره‌برداری
ندارد
اثر فنی
جزئی

ضعف‌ها (CWE)

  • CWE-400
    Uncontrolled Resource Consumption