جزئیات آسیب‌پذیری

CVE-2025-48877

discourse discourse

Discourse vulnerable to auto-executing of third-party code in embedded CodePen iframe

CVSS 4.0
8.1بالا

شرح رسمی (انگلیسی)

Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, Codepen is present in the default `allowed_iframes` site setting, and it can potentially auto-run arbitrary JS in the iframe scope, which is unintended. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. As a workaround, the Codepen prefix can be removed from a site's `allowed_iframes`.

امتیازهای CVSS

امتیازنسخهمنبعبردار
8.1بالا 4.0 CVEProject cvelistV5 (CNA) (GitHub_M) CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
discourse discourse < 3.4.4 CVEProject cvelistV5 (CNA)
discourse discourse < 3.5.0.beta5 CVEProject cvelistV5 (CNA)
discourse discourse < 3.5.0.beta6-dev CVEProject cvelistV5 (CNA)

منابع و راهنماها

۱
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۴/۰۳/۱۹
آخرین به‌روزرسانی
۱۴۰۴/۰۳/۱۹
وضعیت
منتشرشده
صادرکننده (CNA)
GitHub_M

پیش‌بینی بهره‌برداری (EPSS)

۰٫۴۲٪
احتمال بهره‌برداری در ۳۰ روز
۳۷٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
بله
وضعیت بهره‌برداری
ندارد
اثر فنی
جزئی

ضعف‌ها (CWE)

  • CWE-1038
    Insecure Automated Optimizations