جزئیات آسیب‌پذیری

CVE-2025-27423

vim vim

Improper Input Validation in Vim

CVSS 3.1
7.1بالا

شرح رسمی (انگلیسی)

Vim is an open source, command line text editor. Vim is distributed with the tar.vim plugin, that allows easy editing and viewing of (compressed or uncompressed) tar files. Starting with 9.1.0858, the tar.vim plugin uses the ":read" ex command line to append below the cursor position, however the is not sanitized and is taken literally from the tar archive. This allows to execute shell commands via special crafted tar archives. Whether this really happens, depends on the shell being used ('shell' option, which is set using $SHELL). The issue has been fixed as of Vim patch v9.1.1164

امتیازهای CVSS

امتیازنسخهمنبعبردار
7.1بالا 3.1 CVEProject cvelistV5 (CNA) (GitHub_M) CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
vim vim < 9.1.1164 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۴
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۳/۱۲/۱۳
آخرین به‌روزرسانی
۱۴۰۴/۰۲/۱۳
وضعیت
منتشرشده
صادرکننده (CNA)
GitHub_M

پیش‌بینی بهره‌برداری (EPSS)

۲۲٫۴۷٪
احتمال بهره‌برداری در ۳۰ روز
۹۷٫۷٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
خیر
وضعیت بهره‌برداری
ندارد
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-77
    Improper Neutralization of Special Elements used in a Command ('Command Injection')