جزئیات آسیب‌پذیری

CVE-2025-23015

Apache Software Foundation Apache Cassandra

Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions

CVSS 3.1
8.8بالا

شرح رسمی (انگلیسی)

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

امتیازهای CVSS

امتیازنسخهمنبعبردار
8.8بالا 3.1 CISA ADP / Vulnrichment (CISA-ADP) CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
Apache Software Foundation Apache Cassandra 3.0.0 ≤ v ≤ 3.0.30 CVEProject cvelistV5 (CNA)
Apache Software Foundation Apache Cassandra 3.1.0 ≤ v ≤ 3.11.17 CVEProject cvelistV5 (CNA)
Apache Software Foundation Apache Cassandra 4.0.0 ≤ v ≤ 4.0.15 CVEProject cvelistV5 (CNA)
Apache Software Foundation Apache Cassandra 4.1.0 ≤ v ≤ 4.1.7 CVEProject cvelistV5 (CNA)
Apache Software Foundation Apache Cassandra 5.0.0 ≤ v ≤ 5.0.2 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۴
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۳/۱۱/۱۶
آخرین به‌روزرسانی
۱۴۰۳/۱۱/۲۷
وضعیت
منتشرشده
صادرکننده (CNA)
apache

پیش‌بینی بهره‌برداری (EPSS)

۱٫۰۱٪
احتمال بهره‌برداری در ۳۰ روز
۶۳٫۲٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
خیر
وضعیت بهره‌برداری
ندارد
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-267
    Privilege Defined With Unsafe Actions