جزئیات آسیب‌پذیری

CVE-2024-10124

ThemeHunk Vayu Blocks – Website Builder for the Block Editor

Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce <= 1.1.1 - Missing Authorization to Unauthenticated Arbitrary Plugin Installation/Activation

CVSS 3.1
9.8بحرانی

شرح رسمی (انگلیسی)

The Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary plugin installation and activation due to a missing capability check on the tp_install() function in all versions up to, and including, 1.1.1. This makes it possible for unauthenticated attackers to install and activate arbitrary plugins which can be leveraged to achieve remote code execution if another vulnerable plugin is installed and activated. This vulnerability was partially patched in version 1.1.1.

امتیازهای CVSS

امتیازنسخهمنبعبردار
9.8بحرانی 3.1 CVEProject cvelistV5 (CNA) (Wordfence) CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
ThemeHunk Vayu Blocks – Website Builder for the Block Editor v ≤ 1.1.1 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۶
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۳/۰۹/۲۲
آخرین به‌روزرسانی
۱۴۰۵/۰۱/۱۹
وضعیت
منتشرشده
صادرکننده (CNA)
Wordfence

پیش‌بینی بهره‌برداری (EPSS)

۳۲٫۷۱٪
احتمال بهره‌برداری در ۳۰ روز
۹۸٫۳٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
بله
وضعیت بهره‌برداری
ندارد
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-284
    Improper Access Control