جزئیات آسیب‌پذیری

CVE-2023-33246

بهره‌برداری فعال
Apache Software Foundation Apache RocketMQ

Apache RocketMQ: Possible remote code execution vulnerability when using the update configuration function

CVSS 3.1
9.8بحرانی

شرح رسمی (انگلیسی)

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

امتیازهای CVSS

امتیازنسخهمنبعبردار
9.8بحرانی 3.1 CISA ADP / Vulnrichment (CISA-ADP) CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

محصولات آسیب‌پذیر

فروشندهمحصولنسخه‌هامنبع
Apache Software Foundation Apache RocketMQ v ≤ 5.1.0 CVEProject cvelistV5 (CNA)

منابع و راهنماها

۷
هشدار CVEهای بعدی این محصولمحصول را دنبال کنید تا آسیب‌پذیری‌های تازه را در تلگرام بگیرید.

اطلاعات

تاریخ انتشار
۱۴۰۲/۰۳/۰۳
آخرین به‌روزرسانی
۱۴۰۴/۰۷/۳۰
وضعیت
منتشرشده
صادرکننده (CNA)
apache

فهرست KEV آژانس CISA

تاریخ افزوده‌شدن
۱۴۰۲/۰۶/۱۵
مهلت رفع
۱۴۰۲/۰۷/۰۵
استفاده در باج‌افزار
نامشخص

پیش‌بینی بهره‌برداری (EPSS)

۹۶٫۵۶٪
احتمال بهره‌برداری در ۳۰ روز
۹۹٫۸٪
صدک (نسبت به همه‌ی CVEها)

ارزیابی SSVC (CISA)

قابل خودکارسازی
بله
وضعیت بهره‌برداری
فعال
اثر فنی
کامل

ضعف‌ها (CWE)

  • CWE-94
    Improper Control of Generation of Code ('Code Injection')